Posted 2026-09-05 | Back to blog index
So my Synology NAS has started throwing Btrfs Checksum errors on some files. It's always the same files, and some of them are files that haven't changed in ages. Not a good sign.
The disks aren't throwing any SMART errors, UDMA CRC or otherwise, so the obvious next thing to check is for bad RAM.
When I bought this DS918+ back 8 years ago, I also replaced the factory 4 GB of RAM with two third-party 8 GB sticks for a total of 16 GB. Then lost the factory stick somewhere.
So off to HARDOFF I go, and 5000 yen later I have an HP laptop that is compatible with the same RAM so I can run memtest86. Also picked up a 4 GB and 8 GB stick in case I need a replacement (and so I have something to use in the laptop once it's done with this task!)
memtest86 is now running... I'm praying for a failure. Because if the RAM is good, that means there's something worse broken with my NAS (CPU? memory controller? slot? PCB?) which sounds expensive/annoying.
I've never run memtest86 before in my life, can you tell? I just learned there's an SEO-squatting ripoff paid version, and an open source version, and you need the latter to leave passes going overnight.
I also had to learn how to turn off Secure Boot, like a real PC user. Gross.
So after a lot of testing:
* All the RAM passes all tests in the test computer I bought
* I managed to get the Synology to boot&run ramtest on single sticks, one of the old sticks fails, all others pass
Realized that the Synology runs RAM at 1866 MT/s. The old RAM was 1866 MT/s. The test computer I bought is only 1600 MT/s.
So, one of the old sticks went marginal - it's fine at 1600 MT/s, but fails at its sticker-rated 1866 MT/s.
The “new” RAM I got out of the bin at HARD OFF was also 1600 MT/s.
So what I've ended up doing is putting the new 1600 sticks in the NAS, and the old 1866 sticks in the laptop. I don't trust the second old stick to hold up when its friend just went bad after 8 years.
And the adage is proven: you really want ECC RAM in a NAS running Btrfs (and presumably ZFS).
The file system did that thing where it “repaired a bad checksum” to bad data since the RAM that calculated the checksum was bad, corrupting the data.
Good thing I caught the checksum errors early thanks to the email alerts. Make sure you have those on your NAS!
Well, time will tell. We'll see in the upcoming days if the checksum errors disappear or not. I could still be barking up the wrong tree…
So... Um... Who wants an HP laptop from 2017? It's Made in Tokyo!!
With the new-to-me RAM, the system completed a full scrub with no checksum errors. The problem seems solved! Hooray!