So my Synology NAS has started throwing Btrfs Checksum errors on some files

Posted 2026-09-05 | Back to blog index

So my Synology NAS has started throwing Btrfs Checksum errors on some files. It's always the same files, and some of them are files that haven't changed in ages. Not a good sign.

The disks aren't throwing any SMART errors, UDMA CRC or otherwise, so the obvious next thing to check is for bad RAM.

When I bought this DS918+ back 8 years ago, I also replaced the factory 4 GB of RAM with two third-party 8 GB sticks for a total of 16 GB. Then lost the factory stick somewhere.

A screenshot of a tableUserEventSYSTEMChecksum mismatch on file [/volume2/Time MachinSYSTEMChecksum mismatch on file [/volume2/Time MachinSYSTEMChecksum mismatch on file [/volume2/Time MachinSYSTEMChecksum mismatch on file [/volume2/Time MachinSYSTEMChecksum mismatch on file [/volume2/Time Machin

So off to HARDOFF I go, and 5000 yen later I have an HP laptop that is compatible with the same RAM so I can run memtest86. Also picked up a 4 GB and 8 GB stick in case I need a replacement (and so I have something to use in the laptop once it's done with this task!)

memtest86 is now running... I'm praying for a failure. Because if the RAM is good, that means there's something worse broken with my NAS (CPU? memory controller? slot? PCB?) which sounds expensive/annoying.

A blue carry bag with the HARD OFF logo in yellow A blue bin full of laptop RAM. Two sticks are circled in red. A big chunky laptop with an HP logo and a 3000 yen price tag. On top of it is a 550 yen power brick, a 550 YEN 4 GB memory stick, and a 1000 yen 8 GB memory stick. A photo of a laptop screen running memtest86

I've never run memtest86 before in my life, can you tell? I just learned there's an SEO-squatting ripoff paid version, and an open source version, and you need the latter to leave passes going overnight.

I also had to learn how to turn off Secure Boot, like a real PC user. Gross.

A blue memtest TUI centered on the middle of the screen

Update on 2026-09-06:

So after a lot of testing:

* All the RAM passes all tests in the test computer I bought

* I managed to get the Synology to boot&run ramtest on single sticks, one of the old sticks fails, all others pass

Realized that the Synology runs RAM at 1866 MT/s. The old RAM was 1866 MT/s. The test computer I bought is only 1600 MT/s.

So, one of the old sticks went marginal - it's fine at 1600 MT/s, but fails at its sticker-rated 1866 MT/s.

The “new” RAM I got out of the bin at HARD OFF was also 1600 MT/s.

So what I've ended up doing is putting the new 1600 sticks in the NAS, and the old 1866 sticks in the laptop. I don't trust the second old stick to hold up when its friend just went bad after 8 years.

And the adage is proven: you really want ECC RAM in a NAS running Btrfs (and presumably ZFS).

The file system did that thing where it “repaired a bad checksum” to bad data since the RAM that calculated the checksum was bad, corrupting the data.

Good thing I caught the checksum errors early thanks to the email alerts. Make sure you have those on your NAS!

Well, time will tell. We'll see in the upcoming days if the checksum errors disappear or not. I could still be barking up the wrong tree…

So... Um... Who wants an HP laptop from 2017? It's Made in Tokyo!!

A very PC looking laptop complete with crappy offset trackpad. Above the top left of the screen it says Made in TokyoIt is showing neofetch on Ubuntu revealing HP ProBook 450 G3, Intel i3-6100U, Skylake GT2 HD Graphics, 16 GB RAM

Update on 2026-09-09:

With the new-to-me RAM, the system completed a full scrub with no checksum errors. The problem seems solved! Hooray!

A screenshotEvent DetailCategory: StorageSubject: The system completed data scrubbing on Storage Pool 2.Time: 2026-09-09 01:29:45The system completed data scrubbing on Storage Pool 2.

Back to blog index